これよりデータベースサーバー更新作業のため当インスタンスのサーバーを全停止します。
終了予定時刻は 15:30 です。

サーバーメンテナンス終了しました。
更新作業中に障害が発生し、約 30 分間のトゥートを欠損しました。
申し訳ありません。
その他異常がありましたら教えていただけると幸いです。

フォロー

再発防止策として次のようにします。
・DB 更新後、稼働開始させる前に DB に直接接続し簡易チェックを実施するようにします。
・上記を作業マニュアルに追記し、マニュアルを整備し近日中に公開できるようにします。

DB 同士の比較は現在の方法ではできません。
( DB 鯖が 1 台だけかつ競合ライブラリがあり新旧同時稼働は危険と考えています

私は PostgreSQL のメジャーバージョンアップ時にいつもトラブルを起こしているのでできれば先延ばしにしたかったのですが、PostgreSQL 公式 apt リポジトリには postgresql-contrib が 10.x 用・ 11.x 用共用でしか存在せず、postgresql-contrib のセキュリティアップデートを適用するには PostgreSQL 11.x をインストールする以外の手が見当たりませんでした。

ログインして会話に参加
taruntarun.net

taruntarun.net - Mastodon